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Windows XP Embedded @

1 Getting Started

1.1 Introduction

Welcome to the Windows XP Embedded install guide for Connect Tech Products. This guide
will walk you through the step by step process on getting X Pe setup with a CTI product. This
guideisintended to walk you through each step on setting up your target image with our drivers
and someinitial steps expert XPe users may want to skip.

1.2 Obtaining Driver Files

For driver updates, manuals, and installation guides please check the product CD or the Connect
Tech Download Zone at http://www.connecttech.com/asp/Support/Downl oadZone.asp.

1.3 Contacting Technical Support

If you require assistance please check the Connect Tech product manuals, specification sheets, or
Knowledge Database (KDB) at http://www.connecttech.com/sub/Support/Support.asp.

If you have any further questions please contact the Technical Support department by email at
support@connecttech.com.
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2 Working with CTI Drivers in XP Embedded

2.1 Installing Driver Files

» If you do not have the product CD, Download ctixpel00.zip for our download zone.
» Extract to alocation on your system (eg. ..\desktop\ctixpet##\)

* If you do have the product CD, please ignore the previous 2 steps.

*  Open Microsoft Component Database M anager

* Inthe Database Tab Select Import.

& Microsoft Component Database Manager (Exclusive Mode)

Databasze ]Elatform] Pacl_<age1 Eomponent] Bepository] Qroup]

Databasze connection

Target Designer and Component Designer must connect bo a component database
zerver to function comrectly.

Database server location:

P4LA

Change...

Impart -

Import an SLO file into the component database.

About... Cloze Help
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* Inthe SLD File section browse to the extracted sld (eg. ..\desktop\ctixpet##ctixpe.sld
OR brose to %CDROM%\windows_XPe\ctixpe.sld)

* Make surethe "Copy repository files to repository root" box is checked off and Select
Import

& Import SLD

SLD file:
]K:'xD acument: and Settingz’\Administrator D esktophctispel 004ctidpe.

Bepogitary roat;
| WWPALANR epositories -l

Results:

[v Copy repository files to repositary root

Irport Cloze Help

* Results of the sld import will be displayed, Select Close and then Close again to exit the
Microsoft Component Database M anager

* (Now if you wish you may delete the extracted driver files from your downloaded
location (eg...\desktop\ctixpet#))

* Run tap.exe (Which is found \program files\windows embedded\utilities\) on your target
system collect the target hardware info. tap.exe gathers accurate info about the hardware
including the specs of IDE controller and other motherboard devices.

» tap.exewill generate a devices.pmq save this file and make sure you are able to access it
from your devel opment system.
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2.2 Creating Target Image with CTI Drivers

* Open Microsoft Target Designer

* Select File->New

» Choose your Platfrom Architecture and Configuration Name

* Now will start with ablank configuration file/workspace

» Toimport your target systems hardware into this configuration Select File->Import

* Now Select the devices.pmq or whatever you have named you target systems .pmq file
and select Start

* Your target systems hardware will begin to be imported in to your configuration, this may
take several minutes.

Import File FZ|
Platform: \indiows <P Embedded Clent (+86) |
File: IK: “Program Files\WWwindows Embeddedsutiities\devices. prg |
Log file; | |
Status: Ainalyzing El Tonto CO.

[T ]

! @ Ready to start import session .
@Processing file : K:A\Pragram Filzs\windows Embeddadiutilitieshdevices. pma
@Target.&nal}lzer found 75 devices.
@ Loading the driver databasze. [3:4212 Ak)]

Cancel ] [ Help
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*  When thisis complete your Target Designer will now be showing your configurations
with the all of the detected hardware components from your target device added in.

t Designer - FINALFF104.slx

Fle Edt View Configuration Tools Help

N2H|%fh@X ) | @ )
x5 =
T El Settings. — | Name: |Wmdnws P Embedded Client 426) ‘
Fiter: |l Comporents 4 i ‘;Ies
Search: | | @ B Extra Registry Data Version 1o | Revison 2 |
10383 components &y Components Ownerls} | | ot | |
- & ACPIFan[s 1,2600,R620]
il e bry (3 ACPI Fixed Feature Button [Yersion 5.1 2600,8620] Verdor: | Microsolt | Copyigh: |Copwint ) 2007 Wi |
) softere & ACPI Multiprocessor PC [Version 5. 1.2600.2180,R2590] =
(= Desn Teret 9 (3 ACPI Power Button [Version 5.1.2600,R670] Croated:  [2/222007S4014AM | Roviced: 202272007 1008494 |
& ACPI Thermal Zone [Wersion 5. 1.2600,R620]
& Audio Codecs [Version 5.1.2600,RE620] Description: Configuration of Miciosoft(R) Wwindows XP Embedded Client
& CD-ROM Drive [Version 5.1.2600,R620] Platform Defintion
[ () Communications Port [Version 5.1.2600,R620] | |
=}

Direct memory access contraller [Version 5.1.2600,R620] i
Direct Parallel [Version 5.1.2600,7820] Build type: Release
Disk drive [¥ersion 5.1,2600,R620]

Floppy dis drive [Version 5.1,2600,R620]

Inte! Processor [Version 5.1.2600.2180,R7890]

Inte(R) 82501 PCI Bridge - Z4H4E [Version 5.1.2600.2180,R2890]
Intei) 52802 Firmware Hub Device [Version 5.1,2600,R620]
ISAPHP Read Data Port [Version 5. 1.2600,R620]

Legacy Audis Drivers [version 5.1,2600 RE20]

Legacy vidko Capture Devices [Version 5.1,2600,620]

Lol Disk Manager [Version 5.1.2600,R620]

Media Control Devices [Version 5.1.2600,R620]

Mirocode Update Device [Version 5.1,2600,R620]

Microsoft ACPI-Complant System [Yersion 5.1,2600,R620]

Micr Driver [Version 5.1.2600.2180,f
Motherboard resaurces [Version 5. 1,2600,R620]
humeric dsta processor [Version 5. 1.2600,R620]

Patket Scheduler Miniport [version 5.1,2600,R620]

PCI bus [Version 5.1,2600,R620]

PCI standard host CPLI bridge [Version 5.1.2600,R620]

PCI standard 154 bridge [Yersion 5.1 2600,R620]

PCI standard PCI-ta-PCT bridge [Version 5.1.2600,R620]

Plug and Play Manitar [¥ersion 5.1,2600,R520]

Plug and Play Softuware Device Enumerator [Yersion 5.1.2600,R620]

Primary IDE Chanel[version 5. 1.2600. 2180,RZ890]

Programmable nterrupt controller [Version 5.1.2600,REZ0]

P52 Compatibls Mouse [Version 5. 1,2600,R620]

RA Async Adapter [Version 5.1, 2600,R620]

&
&
&
&
Y
S
S
S

&

&
&
&
&
&
S
S
&
&

o
-
-
X
X

- A nn 2100 noenn e
& | >

=
| starcing configuravion activavion sv: 2/22/2007 10:46:47 AML

CEDE: 0.13 secs, 9 rags. secs, S reqs, 0% hits, D emtries

dctivation complete, slapsed time: 0.61 ssconds

o errors or warnings

[T Tasks ) Messages /£ Debug

Ready 56 Companents +374 KB 6076 KB PaLA Expert Mode UM

* Now to add any Connect Tech products to your target, smply create afilter to show al
CTI component files.

e To Create afilter goto Tools->Filter Manager->New

Filter Manager

Auvailable filter lisk:

Filter descriptian:

[ Cloze ] [ Help




* Now to create the rule enter Name as "Connect Tech”, under filter rules be sure that
"Component display name contains [substring]"” is selected.

» Select Add Rule then double-click on the filter description whereis says double click
here, and enter in the string "Connect Tech" the select OK. Then OK once more to exit
from the creating the filter.

M ame: EEonnect Tech |
1

Filker miles:

Companent display name containg [substring] ~
Component description containg [substring)

Companent vendar name containg [substring)

Companent verzioh string containg [substring)

Companent iz configurable by the uzer

Component can be included in the configuration multiple times

Crranmnant conbsineg Haa Fallmosinn file: Thilalis

Enter String:
Combine using: &) aND () OR Add Fule .

| Connect Tech |

£

Filter description:

Companent dizplay hame containg [Double click here]

[ QK. ] ’ Cancel ] ’ Help ]

[elete Ruls

ak ] [ Cancel ][ Help ]

* Then once returned to the Filter Manager Select Apply Filter.

* Now on theleft hand side only the Connect Tech components will be shown, switch to
list view to easily see the CTI1 components.

o Microsoft Target Designer - FINALFF104.slx*

File Edt View Configration Tools Help

D2H s haxil|v Qe Q?'EE L}

x| [ & ] FINALFF104.5lx * ~
Fiter: | Connect Tech v 7 B Settings
Extra Files
Search: | | & 3’ Extra Registry Data
=] Extrs Resources
components (= 4 Camponents

f (5 ACPI Fan [Yersion 5.1.2600,R620]

[ (53 ACPT Fixed Feature Button [Version 5.1.2600,R620]

B (5 ACPI Multiprocessor PC [Version 5.1.2600.2180,R2850]

[ (5 ACPI Power Button [Version 5.1,2600,R620]

[ (53 ACPT Thermal Zone [Version 5.1.2600,R620]

B (53 Audio Codecs [Version 5.1.2600,R620]

B (5 CD-ROM Drive [Version 5.1.2600,R620]

[ {23 Communications Port [Version 5.1.2600,R620]

[ (3 Direct memory access controller [Wersion 5.1.2600,R620]

i (53 Direct Parallel [Version 5.1.2600,R620]

f) (5 Disk drive [Version 5.1,2600,R620]

& Floppy disk drive [Wersion 5.1.2600,R620]

B (53 Intel Processor [Version 5.1,2600.2180,R2590]

B (53 Intel(R) 82801 PCI Bridge - 244E [Version 5.1.2600.2180,R2890]
[ (53 Intel(r) 52602 Firmware Hub Devics [Version 5.1.2600,r620]
B (53 ISAPNP Read Data Port [Yersion 5.1.2600,R820]

B (5§ Legacy Audio Drivers [Version 5.1.2600,R620]

[ 23 Legacy Viden Capture Devicss [Version 5.1,2600,R620]

[ 23 Logical Disk Managsr [Version 5.1.2600,k620]

B (53 Media Control Devices [Version 5.1,2600,R620]

f# (5 Microcode Update Device [Version 5.1.2600,R620]

[ 3 Microsoft ACP1-Compliant System [Version 5.1.2600,R620]
B (53 Microsoft System Management BIOS Driver [ersion 5.1.2600.2180,R;
B (53 Motherboard resources [Version 5.1.2600,R620]

[ 53 Numeric data processor [ersion 5.1.2600,R820]

B (53 Packet Scheduler Minjport [Version 5.1.2600,R620]

B (53 PCI bus [Yersion 5.1.2600,R620]

[ 23 PCI standard host CPU bridge [Version 5.1,2600,R620]

[ (59 PCI standard ISA bridge [Version 5.1.2600,R620]

~Switch to 'List View"
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* Now simply select the component you would like added and right click on it and goto
Add. Repeat thisfor al of the CTl components.

* Now save your Target, thiswill bean .dx file.

* Now you will need to check your dependencies, before doing this you will need to enable
the "Auto Resolve Dependencies’ feature. To do this goto Tools->Options.

* Theninthe options window goto the Dependency Check Tab and check off the Auto
Resolve Dependencies check box. Select OK to exit the options.

« Sdect Configuration->Check Dependencies, when this completesit will list some
dependency errors and will require you to choose the between additional components.

Hereisalist of typical dependency errors and how to resolve them:

Component
figdij
aweij
iwjefioiweo
iwjefiowe o]

] .\:3 Secondary IDE Channel [Yersion 5.1, 2600,2160,R2590]

= \\B Session Manager (Windows subsystem) [Version 5.1,2600,2180,R28%
[ \“B Standard 101/102-Key or Microsoft Natural PSf2 Keyboard [Yersion 5.
=] \*ﬁ Standard Dual Channel PCT IDE Contraller [Yersion 5,1,2600,2180,R2¢
(-2 Standard Enhanced PCI ko UISE Host Controller [Yersion 5,1.2600, 218
= d Standard floppy disk controller [Yersion 5.1.2600,R620]

[+ ‘CB Standard Universal PCI to USE Hosk Controller [Version 5.1.2600.2180
3] .\\3 System board [Version 5.1,2600,R620]

[ \“B Syskem CMOS/real time clock [Version 5.1,2600,R620]

(=] QB System speaker [Version 5,1,2600,R620]

=] \*ﬁ System timer [Version 5,1, 2600,R620]

(-2 Terminal Server Device Redirector [Version 5.1, 2600,R620]

= d Terminal Server Keyboard Driver [Version 5. 1.2600,RE20]

3] .\\3 Terminal Server Mouse Driver [Version 5.1,2600,R620]

& \*a LI 0

Task Mame &

L

000000
CEEEEE

Component: "CO-ROM Drive [Version 5.1,2600, RE620]" requires at least one additional enabled component: not in the configuration
Compenent: "Communications Port [Yersion 5.1.2600, R620]" requires additional enabled components not in the configuration
Camponent: "Communications Port [Wersion 5.1.2600, R620]" requires at least one additional enabled component not in the configuration
Component: "Connect Tech FreeForm 104 [Yersion 1,06, RE]" requires additional enabled components not in the configuration
Component: "Direct memory access controller [Yersion S,1,2600, R620]" requires additional enabled components not in the configuration
)| Component: "Direct Parallel [Version 5,1.2600, Re20]" requires additional enabled components not in the configuration

] J Component: "Direct Parallel [Version 5, 1,2600, RE20]" requires at least one additional enabled component nat in the configuration

] j Component: "Direct Parallel [Version 5, 1,2600, RE20]" requires at least one additional enabled component nat in the configuration

Read.»:

e Go back to Check dependencies and repeat the steps until there are no errors.

10
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Dependency Check @

Pragress:

[IIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII]

| Checking "Rich Edit Contral Yersion 3.0 [Version 5.1, 26002180, R2890]".. Al
|Checking: "Certificate User Interface Services [Version 5.1, 26001108, R15077".. |
|Checking: "Core Certificate Services [Wersion 5.1.2600. 2180, R2830]"...

| Checking: "Cryptographic Metwork, Services [Wersion 5.1.2600 2180, R2830]". .

|Checking: "Smart Card Cryptographic Service Providers [Werzion 5.1.2600.2180, R2830]"...

| Checking: ""Primitive; Duger [Wersion 5.1.2600.2180, R2830]"...

Checking "Rich Edit Contral Version 1.0 [Version 5.1 2600, RE20]". |

| Checking: "Primitive; SEMSAPI [Wersion 5.1.2600.2180, R2830]"...

Checking: "Smart card Subsystem [Version 5.1.2600.2180, R2830]"...

| Checking: "Explarer zhell [Wersion 5.1.2600.1106, R1507]"...

|CFDB: 203 zecz, bE1 reqs. LAR: 2 36 secs. 2969 regs. 81% hitz, 200 entriez

|Check complete, elapsed time: 9,38 seconds

Mo errars ar warnings

LCloze ] [ Help

e Sdect Close.

The next step will be to build your image, before doing as anote if you are booting your target
device on the same hard drive please read and compl ete the following below. If your target
device will not be on the same hard drive as your development system please skip this section.

So for your development device you will need to change your target device settings so it will boot
correctly. To do thisfirst modify your development machines boot.ini file to include your XPe
partition. (eg. add the line " multi(0)disk(0)rdisk(O)partition(3)\WINDOWS="Test -XPe"
[fastdetect ") once your devel opment machines boot.ini file is modified the next step is to change
your XPe client target settings. To view and change these click on the settings under your .slx
filetree.

ﬁ’ Exkra Reqgistry Data
[=] Extra Resources
#- 5 Components

Now in the right column click show under Target Device Settings. Then here you will see the
boot drive configurations, change all of the C: to be the drive letter of the partition you are
booting and also change the Boot ARC path to match thefirst part of the line you added to you
development machines boot.ini file.

11
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$ windows ¥P Embedded Client {x88)

Available Settings:

m Target Device Setkings

m  Confiquration Update and Refresh Settings
= Deployment Identification Settings

m Other Settings

Target Device Sektings
| hide | mare info |

Boot drive {more info) L:

Windows Folder {more info) |L: WAMDOYWYS
Program Files Folder {more info) |L: ‘Frogram Files

Dacuments and Settings folder {more info) |L:\Documems and Settings

Book ARC path {more infa) |mu|ti[D)n:Iisk[ﬂ)rdisk[ﬂ)pamtionﬁj
Boot partition size (ME) (mare infa) 1024

Partition cluster size (bytes) {more info) 4096

Final Stage Building the Image

* Now Select Configuration->Build Target Image (F7)

» Sedlect where you would like the image files to be built and saved to and then select Build.
The build process will take afew minutes, once it is complete click close.

12
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Build type;

Diestination: |K:'\Windows Embedded Images' |D
Log file: |K:'~><F'e Configehnewifl04.log |E]
Progress:

Illllllllllllllllllllllllllllllllllllllllllllllllllllllllllllllll]

System compaonents, registry and other files ... TABEARE A
CFDB: 002 zecs, 1 reqs. LAR: 0.02 secs, 1 reqs, 0% hitz, 200 entries ¥
Files: 847, RegEdits: 16779, Fisups: 7750

Build complete, elapzed time: 6895 secondsz, estimated run-time image size: 119.20mMB / 165 55ME [comp
Mo erorz and 2 warnings

b

2 ! #

Buld | [ Close || Help

2.3 Deploying Target Image with CTI Drivers

* Now copy the build XPe image to your target devices bootable drive, and boot up your
target device.

 TheFBA will start and install all CTI PNP devices. If the product you are using is anon
PNP device (eg. PC/104, I1SA) you will run the add hardware wizard after bootup.

*  When running the add hardware wizard simply select that you aready have the device
connected and then run through the steps and select the appropriate CT1 product from the

list. Now windows will require another reboot then your device will be setup and ready to
use.

13
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3 Known Issues

None at this point.
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